Back to overview
Downtime

downtime

Feb 27, 2026 at 2:51pm UTC
Affected services
lantics.me
i.lantics.me
pawbs.org

Resolved
Feb 27, 2026 at 7:06pm UTC

power came back earlier, wasnt able to turn things back on til now.

Created
Feb 27, 2026 at 2:51pm UTC

power outage. big one.