Back to overview
Downtime
downtime
Feb 22, 2026 at 4:51pm UTC
Affected services
lantics.me
i.lantics.me
pawbs.org
Resolved
Feb 22, 2026 at 6:36pm UTC
power back
Affected services
Created
Feb 22, 2026 at 4:51pm UTC
power outage at datacenter my house. stormy! whoops!
Affected services